Quagga, avec un bug en moins…

dans ipv6

Alors, le mois dernier, en faisant tomber en marche IPv6 sur le backbone de Gitoyen, je suis tombé sur un truc étrange sur le routeur de Gitoyen qui tourne sous FreeBSD (les autres sont sous Linux).

Pour une raison étrange, lorsque le démon zebra recevait une route IPv6 dans sa RIB, et qu’il ne l’avait pas encore, il la mettait dans la FIB du noyau, il découvrait avec un bonheur certain une route IPv6 (celle là même qu’il venait de mettre), la mettait dans sa RIB, et de par le fait qu’il préfère les routes noyau aux routes OSPF, enlevait la route qu’il avait mise (sic), là, voyant que, oh, malheur, il n’y avait plus la route noyau en question (forcément, il venait de l’enlever), remet la route OSPF

J’ai donc été sur #quagga, sur freenode, histoire de papoter et demander si quelqu’un avait déjà rencontré ça, mais il faut avouer que ceux qui utilisent IPv6 sont rares. On m’a donc répondu, et c’est avec grand plaisir que je suis aller ouvrir un ticket sur le bugzilla de quagga, qui est resté la sans vraiment bouger une dizaine de jours.

Hier soir, j’en ai reparlé sur irc, j’ai rajouté quelques petites informations à mon ticket, et quelqu’un m’a dit de tester la version cvs de quagga, et, une compilation plus tard, puis un stop/start de quagga, bgpd, ospfd, ospf6d, j’ai eu la délicieuse surprise de voir que le bug était effectivement parti.

Je vais donc pouvoir envisager l’arrivée du transit IPv6 de Gitoyen avec un backbone qui fonctionne.

Posté par Mathieu Arnold le lundi 3 décembre 2007 à 17:14

Rétroliens (0)

La discussion continue ailleurs…
Adresse du rétrolien : http://w.mat.cc/trackback/53

Commentaires

Poster un commentaire
(facultatif)

« Ézoah, immemoria et Ténébria   La Femme du Monstre »